<!DOCTYPE html>
<!--[if IE 8]><html class="no-js lt-ie9" lang="en-US"><![endif]-->
<!--[if IE 9]><html class="no-js lt-ie10" lang="en-US"><![endif]-->
<!--[if gt IE 8]><!--><html class="no-js" lang="en-US"><!--<![endif]-->
<head>
  <meta charset="UTF-8" />
  <meta http-equiv="X-UA-Compatible" content="IE=10;IE=9;IE=8;IE=7;IE=EDGE,chrome=1" />
  <meta name="viewport" content="width=device-width, initial-scale=1" />

  <link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
  <link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32">
  <link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16">
  <link rel="manifest" href="/manifest.json">
  <link rel="mask-icon" href="/safari-pinned-tab.svg" color="#ec1c24">
  <meta name="apple-mobile-web-app-title" content="Eugene Weekly">
  <meta name="application-name" content="Eugene Weekly">
  <meta name="theme-color" content="#ffffff">

  <title>TajMo Return for Mo’ &#8211; Eugene Weekly</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Eugene Weekly &raquo; Feed" href="https://eug.wkly.ws/feed/" />
<link rel="alternate" type="application/rss+xml" title="Eugene Weekly &raquo; Comments Feed" href="https://eug.wkly.ws/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Eugene Weekly &raquo; iCal Feed" href="https://eug.wkly.ws/calendar/?ical=1" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/eug.wkly.ws\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.7"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ai-core-style-css'  href='https://eug.wkly.ws/wp-content/plugins/hyunsupul-aesop-core-0280b07/public/assets/css/ai-core.css?ver=1' type='text/css' media='all' />
<style id='ai-core-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='dashicons-css'  href='https://eug.wkly.ws/wp-includes/css/dashicons.min.css?ver=4.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='soup2nuts-style-css'  href='https://eug.wkly.ws/wp-content/themes/soup2nuts/assets/css/soup2nuts.css?ver=4.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='wpbdp-widgets-css'  href='https://eug.wkly.ws/wp-content/plugins/business-directory-plugin/assets/css/widgets.min.css?ver=5.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-widget-social-icons-styles-css'  href='https://eug.wkly.ws/wp-content/plugins/jetpack/modules/widgets/social-icons/social-icons.css?ver=20170506' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://eug.wkly.ws/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://eug.wkly.ws/wp-content/plugins/jetpack/css/jetpack.css?ver=6.1' type='text/css' media='all' />
<script type='text/javascript' src='https://eug.wkly.ws/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://eug.wkly.ws/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://eug.wkly.ws/wp-content/plugins/aesop-lazy-loader/lazyload.js?ver=2.0'></script>
<script type='text/javascript' src='https://eug.wkly.ws/wp-content/themes/soup2nuts/assets/js/head.js?ver=4.9.7'></script>
<link rel='https://api.w.org/' href='https://eug.wkly.ws/wp-json/' />
<meta name="generator" content="WordPress 4.9.7" />
<link rel="canonical" href="https://eug.wkly.ws/2018/07/26/tajmo-return-for-mo/" />
<link rel='shortlink' href='https://wp.me/p9Dk0v-vnE' />
<link rel="alternate" type="application/json+oembed" href="https://eug.wkly.ws/wp-json/oembed/1.0/embed?url=https%3A%2F%2Feug.wkly.ws%2F2018%2F07%2F26%2Ftajmo-return-for-mo%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://eug.wkly.ws/wp-json/oembed/1.0/embed?url=https%3A%2F%2Feug.wkly.ws%2F2018%2F07%2F26%2Ftajmo-return-for-mo%2F&#038;format=xml" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://eug.wkly.ws"><link rel="https://theeventscalendar.com/" href="https://eug.wkly.ws/wp-json/tribe/events/v1/" />
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><div class="ad ad-dfp_head-container"><div class="ad-wrapper">	<!-- Include google_services.js -->
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/52631704/970x250_1', [900,250], "acm-ad-tag-900x250-home-before-events").addService(googletag.pubads());
googletag.defineSlot('/52631704/900x250_BTF', [900,250], "acm-ad-tag-900x250-home-after-events").addService(googletag.pubads());
googletag.defineSlot('/52631704/728x90_BTF', [728,90], "acm-ad-tag-728x90-home-after-video").addService(googletag.pubads());
googletag.defineSlot('/52631704/front_728x90_1', [728,90], "acm-ad-tag-Sitewide 728x90 #1").addService(googletag.pubads());
googletag.defineSlot('/52631704/728x90-before-gallery-video', [728,90], "acm-ad-tag-728x90-before-video").addService(googletag.pubads());
googletag.defineSlot('/52631704/300x250-promotions-btf', [300,250], "acm-ad-tag-300x250-promotions-btf").addService(googletag.pubads());
googletag.defineSlot('/52631704/arts_300x250_1', [300,250], "acm-ad-tag-300x250-arts-atf").addService(googletag.pubads());
googletag.defineSlot('/52631704/arts_300x250_3', [300,250], "acm-ad-tag-Arts 300x250 #3").addService(googletag.pubads());
googletag.defineSlot('/52631704/arts_300x600_3', [300,600], "acm-ad-tag-Arts 300x600 #3").addService(googletag.pubads());
googletag.defineSlot('/52631704/culture_300x600_3', [300,600], "acm-ad-tag-300x600-post-footer-btf").addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>
</div></div>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="TajMo Return for Mo’" />
<meta property="og:url" content="https://eug.wkly.ws/2018/07/26/tajmo-return-for-mo/" />
<meta property="og:description" content="Blues musician Keb’ Mo’ had been working nonstop on what would become the Grammy-winning album TajMo. After a weeklong break, he gave it another chance. This time, he took it on a drive.  “I should…" />
<meta property="article:published_time" content="2018-07-26T07:00:12+00:00" />
<meta property="article:modified_time" content="2018-07-25T22:32:07+00:00" />
<meta property="og:site_name" content="Eugene Weekly" />
<meta property="og:image" content="https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-tajmo.jpg" />
<meta property="og:image:width" content="1500" />
<meta property="og:image:height" content="1000" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@eugeneweekly" />
<meta name="twitter:text:title" content="TajMo Return for Mo’" />
<meta name="twitter:image" content="https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-tajmo.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->

<!-- BEGIN GADWP v5.3.3 Universal Analytics - https://exactmetrics.com/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-617157-1', 'auto');
  ga('set', 'forceSSL', true);
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->
</head>

<body class="post-template-default single single-post postid-120630 single-format-standard tribe-no-js tribe-theme-soup2nuts browser-gecko os-windows aesop-core aesop-on-soup2nuts">
<div id="page" class="hfeed site">
  <a class="skip-link screen-reader-text" href="#content">Skip to content</a>

  <header id="masthead" class="site-header" role="banner">
    <div class="site-branding">
      <h1 class="site-title"><a href="https://eug.wkly.ws/" rel="home"><span class="visuallyhidden">Eugene Weekly</span><svg class="icon logo-ew-type"><use xlink:href="https://eug.wkly.ws/wp-content/themes/soup2nuts/assets/svg/sprite.symbol.svg#logo-ew-type" /></svg></a></h1>
      <p class="site-description">We&#039;ve got issues.</p>

      <nav class="navigation-menu category-menu-container"><ul id="category-menu" class="menu"><li id="menu-item-61509" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61509 menu-item-news"><a href="https://eug.wkly.ws/category/news/"><span class="menu-item-title">News</span></a></li>
<li id="menu-item-61510" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-61510 menu-item-arts"><a href="https://eug.wkly.ws/category/arts/"><span class="menu-item-title">Arts</span></a></li>
<li id="menu-item-61511" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61511 menu-item-culture"><a href="https://eug.wkly.ws/category/culture/"><span class="menu-item-title">Culture</span></a></li>
<li id="menu-item-58830" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58830 menu-item-calendar menu-item-has-icon"><a href="https://www.eugeneweekly.com/calendar/"><span class="menu-item-title">Calendar</span><svg class="icon icon-calendar"><use xlink:href="https://eug.wkly.ws/wp-content/themes/soup2nuts/assets/svg/sprite.symbol.svg#icon-calendar" /></svg></a></li>
</ul></nav><!-- .category-nav -->
    </div><!-- .site-branding -->

    <nav id="site-navigation" class="main-navigation" role="navigation">
      <button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
        <span class="menu-label">Menu</span>
        <svg class="icon icon-hamburger"><use xlink:href="https://eug.wkly.ws/wp-content/themes/soup2nuts/assets/svg/sprite.symbol.svg#icon-hamburger" /></svg>        <svg class="icon icon-close"><use xlink:href="https://eug.wkly.ws/wp-content/themes/soup2nuts/assets/svg/sprite.symbol.svg#icon-close" /></svg>      </button>
      <nav class="navigation-menu primary-menu-container"><ul id="primary-menu" class="menu"><li id="menu-item-57006" class="menu-item menu-item-type-post_type_archive menu-item-object-tribe_events menu-item-has-children menu-item-57006 menu-item-calendar menu-item-has-icon"><a href="https://eug.wkly.ws/calendar/"><span class="menu-item-title">Calendar</span><svg class="icon icon-calendar"><use xlink:href="https://eug.wkly.ws/wp-content/themes/soup2nuts/assets/svg/sprite.symbol.svg#icon-calendar" /></svg></a>
<ul class="sub-menu">
	<li id="menu-item-68130" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68130 menu-item-submit-an-event"><a href="https://www.eugeneweekly.com/calendar/event/add"><span class="menu-item-title">Submit An Event</span></a></li>
</ul>
</li>
<li id="menu-item-56853" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56853 menu-item-news"><a href="https://eug.wkly.ws/category/news/"><span class="menu-item-title">News</span></a></li>
<li id="menu-item-56832" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-56832 menu-item-arts"><a href="https://eug.wkly.ws/category/arts/"><span class="menu-item-title">Arts</span></a></li>
<li id="menu-item-56837" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56837 menu-item-culture"><a href="https://eug.wkly.ws/category/culture/"><span class="menu-item-title">Culture</span></a></li>
<li id="menu-item-56852" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-56852 menu-item-music"><a href="https://eug.wkly.ws/category/arts/music/"><span class="menu-item-title">Music</span></a></li>
<li id="menu-item-56856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-56856 menu-item-opinion"><a href="https://eug.wkly.ws/category/news/opinion/"><span class="menu-item-title">Opinion</span></a>
<ul class="sub-menu">
	<li id="menu-item-67221" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-67221 menu-item-slant"><a href="https://eug.wkly.ws/category/news/opinion/slant/"><span class="menu-item-title">Slant</span></a></li>
	<li id="menu-item-67220" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-67220 menu-item-letters"><a href="https://eug.wkly.ws/category/news/opinion/letters/"><span class="menu-item-title">Letters</span></a></li>
</ul>
</li>
<li id="menu-item-61516" class="nav-more menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-61516 menu-item-more menu-item-has-icon"><a href="#"><span class="menu-item-title">MORE</span><svg class="icon icon-next"><use xlink:href="https://eug.wkly.ws/wp-content/themes/soup2nuts/assets/svg/sprite.symbol.svg#icon-next" /></svg></a>
<ul class="sub-menu">
	<li id="menu-item-56867" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56867 menu-item-visual-arts"><a href="https://eug.wkly.ws/category/arts/visual-arts/"><span class="menu-item-title">Visual Arts</span></a></li>
	<li id="menu-item-67209" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-67209 menu-item-performing-arts"><a href="https://eug.wkly.ws/category/arts/performing-arts/"><span class="menu-item-title">Performing Arts</span></a></li>
	<li id="menu-item-56842" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56842 menu-item-film"><a href="https://eug.wkly.ws/category/arts/film/"><span class="menu-item-title">Film</span></a></li>
	<li id="menu-item-67211" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-67211 menu-item-chow"><a href="https://eug.wkly.ws/category/culture/chow/"><span class="menu-item-title">Chow</span></a></li>
	<li id="menu-item-67212" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-67212 menu-item-drink"><a href="https://eug.wkly.ws/category/culture/drink/"><span class="menu-item-title">Drink</span></a></li>
	<li id="menu-item-61517" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61517 menu-item-cannabis"><a href="https://eug.wkly.ws/category/culture/cannabis/"><span class="menu-item-title">Cannabis</span></a></li>
	<li id="menu-item-56860" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56860 menu-item-savage-love"><a href="https://eug.wkly.ws/category/culture/savage-love/"><span class="menu-item-title">Savage Love</span></a></li>
	<li id="menu-item-67214" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-67214 menu-item-outdoors"><a href="https://eug.wkly.ws/category/culture/outdoors/"><span class="menu-item-title">Outdoors</span></a></li>
</ul>
</li>
</ul></nav>    </nav><!-- #site-navigation -->

    <div class="widget widget_wpcom_social_media_icons_widget"><ul><li><a href="https://www.facebook.com/eugeneweekly/" class="genericon genericon-facebook" target="_blank"><span class="screen-reader-text">View eugeneweekly&#8217;s profile on Facebook</span></a></li><li><a href="https://twitter.com/eugeneweekly/" class="genericon genericon-twitter" target="_blank"><span class="screen-reader-text">View eugeneweekly&#8217;s profile on Twitter</span></a></li><li><a href="https://www.instagram.com/eugeneweekly/" class="genericon genericon-instagram" target="_blank"><span class="screen-reader-text">View eugeneweekly&#8217;s profile on Instagram</span></a></li></ul></div>
    <div class="right-column">

      <div class="widget widget_search">
<form role="search" method="get" class="search-form" action="https://eug.wkly.ws/">
  <label for="s" class="search-trigger">
    <span class="search-label">Search</span>
    <svg class="icon icon-search"><use xlink:href="https://eug.wkly.ws/wp-content/themes/soup2nuts/assets/svg/sprite.symbol.svg#icon-search" /></svg>    <svg class="icon icon-close"><use xlink:href="https://eug.wkly.ws/wp-content/themes/soup2nuts/assets/svg/sprite.symbol.svg#icon-close" /></svg>  </label>
  <div class="search-wrapper">
    <label class="search-label">
      <span class="screen-reader-text">Search</span>
      <input type="search" class="search-field" placeholder="Search" data-mobile-placeholder="Search&hellip;" data-tablet-placeholder="What are you looking for?" value="" name="s" title="Search for:" />
    </label>
    <span class="submit-wrapper">
      <button type="submit" class="search-submit" aria-role="button">
        <span class="screen-reader-text">Search</span>
        <svg class="icon icon-search"><use xlink:href="https://eug.wkly.ws/wp-content/themes/soup2nuts/assets/svg/sprite.symbol.svg#icon-search" /></svg>      </button>
    </span>
  </div>
</form>
</div><!-- .widget-search -->

      <nav class="navigation-menu contact-menu-container"><ul id="contact-menu" class="menu"><li id="menu-item-58829" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58829 menu-item-contact-us"><a href="https://eug.wkly.ws/contact-us/"><span class="menu-item-title">Contact Us</span><svg class="icon icon-contact"><use xlink:href="https://eug.wkly.ws/wp-content/themes/soup2nuts/assets/svg/sprite.symbol.svg#icon-contact" /></svg></a></li>
</ul></nav><!-- .contact-icon -->
    </div>
  </header><!-- #masthead -->

  <div id="content" class="site-content">

  <div id="primary" class="content-area">
    <main id="main" class="site-main" role="main">

    
      
        
<article id="post-120630" class="post-120630 post type-post status-publish format-standard has-post-thumbnail hentry category-music has-post-img">
  <figure class="entry-hero">
    <img width="1300" height="844" src="https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-tajmo-1300x844.jpg" class="aesop-lazy-img_not-yet" alt="" style="" />  </figure><!-- .entry-hero -->

  <header class="entry-header">
    <h1 class="entry-title">TajMo Return for Mo’</h1>    
    <div class="entry-meta">
      <span class="excerpt-meta-item meta-item post-categories"><a href="https://eug.wkly.ws/category/arts/music/" class="post-category">Music</a></span> by <span class="byline"><span class="author vcard"><a class="url fn n" href="https://eug.wkly.ws/author/henry-houston/">Henry Houston</a></span></span>Posted on <span class="posted-on"><a href="https://eug.wkly.ws/2018/07/26/tajmo-return-for-mo/" rel="bookmark"><time class="entry-date published updated" datetime="2018-07-26T00:00:12+00:00">07/26/2018</time></a></span><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-120630" class="share-facebook sd-button share-icon no-text" href="https://eug.wkly.ws/2018/07/26/tajmo-return-for-mo/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-120630" class="share-twitter sd-button share-icon no-text" href="https://eug.wkly.ws/2018/07/26/tajmo-return-for-mo/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://eug.wkly.ws/2018/07/26/tajmo-return-for-mo/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="https://eug.wkly.ws/2018/07/26/tajmo-return-for-mo/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>    </div><!-- .entry-meta -->
  </header><!-- .entry-header -->

  <div class="entry-content">
    <p>Blues musician Keb’ Mo’ had been working nonstop on what would become the Grammy-winning album <i>TajMo</i>. After a weeklong break, he gave it another chance. This time, he took it on a drive. </p>
<p>“I should have been sick of it,” he says. “I rode around with it, and I was like, ‘Yeah, I think we got it.’”</p>
<p>Keb’ Mo’ and blues legend Taj Mahal will come to Eugene — for the second time this year — to support the collaborative album that features original music, blues standards and some pop songs.</p>
<p>Considering the two artists’ history with blues music, a few songs pop out: The Who’s “Squeeze Box” and John Mayer’s “Waiting on the World to Change.” The Mayer song, Keb’ Mo’ says, had some serious “teeth” for a pop song and contrasted the silliness — and innuendo — of The Who’s track. </p>
<p>Keb’ Mo’ was attracted to the Mayer track and Taj Mahal was eager to learn the song. It speaks volumes to Keb’ Mo’s willingness to hunt for good music. Sure, you can consider him a bluesman following the tradition of Robert Johnson — although he doesn’t care much for the marketing term of being “the link” to the Delta Blues — but he knows a good song when he hears one. It’s got a certain characteristic to it. </p>
<p>“For me, I listen to the atmosphere of that music,” he says. “It’s more about what I read of the history. At the times it was being played and formed. And how it was played and how it related to cotton picking, slavery, post slavery, Jim Crow. The sounds of desperation and longing — I just listen to that. I want that longing.”</p>
<p>Keb’ Mo’ says he tries to apply that same sincerity when writing music. He doesn’t look for trends or anything. He aims for his music — and performance — to speak. Maybe that’s why he and Taj Mahal had an immediate chemistry when writing the album. </p>
<p>As this isn’t the first time that Keb’ Mo’ and Taj Mahal have been out on the road in support of the album, the two musicians have their set list down. It features the album, of course, but they also work in a lot of Taj Mahal standards. Keb’ Mo’ says that, when deciding which songs to feature, he asks himself what he would want to hear. That carries a lot of weight for someone who was impressed by Taj Mahal’s performance when he was in high school.  </p>
<p> “It opened the door that there were different things out there,” Keb’ Mo’ says. “All you heard before was the blues your parents listened to — BB King, T-Bone Walker, Bobby Bland — and out walks this big, black hippy dude with a big hat and a steel guitar.”</p>
<p>TajMo, the Taj Mahal and Keb’ Mo’ Band with Alicia Michilli, play 7 pm Friday, July 27, at Cuthbert Amphitheater.</p>
  </div><!-- .entry-content -->

  <footer class="entry-footer">
    <hr class="empty-footer"/>  </footer><!-- .entry-footer -->


  <div class="ad ad-300x600-post-sidebar-atf-container"><div class="ad-wrapper">
		<div id='acm-ad-tag-Arts 300x600 #3' style='width:300px; height:600px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-Arts 300x600 #3'); });
</script>
		</div>
		</div></div>

</article><!-- #post-## -->

        
      
    
    </main><!-- #main -->
  </div><!-- #primary -->


<div id="secondary" class="widget-area" role="complementary">
  <div class="widget">
    <aside id="relatedposts-6" class="widget related_posts">          <h5 class="widget-title">Related Posts</h5>
    
    
<article id="post-120625" class="excerpted-post post-120625 post type-post status-publish format-standard has-post-thumbnail hentry category-music has-post-img no-post-hero">
  <header class="entry-header">
    <h3 class="entry-title"><a href="https://eug.wkly.ws/2018/07/26/summer-standards/" rel="bookmark">Summer Standards</a></h3>
    <h4 class="entry-subhead"><a href="https://eug.wkly.ws/2018/07/26/summer-standards/" rel="bookmark">OFAM opens up the American Songbook one more time</a></h4>
    <div class="entry-meta">
      <span class="excerpt-meta-item meta-item post-categories"><a href="https://eug.wkly.ws/category/arts/music/" class="post-category">Music</a></span> <span class="excerpt-meta-item meta-item posted-on"><a href="https://eug.wkly.ws/2018/07/26/summer-standards/" rel="bookmark"><time class="entry-date published updated" datetime="1532563233">7 hours ago</time></a></span>    </div><!-- .entry-meta -->
  </header><!-- .entry-header -->

    <figure class="entry-hero">
    <a href="https://eug.wkly.ws/2018/07/26/summer-standards/" rel="bookmark">
      <img width="200" height="300" src="https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-redd-200x300.jpg" class="aesop-lazy-img_not-yet" alt="" style="" srcset="https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-redd-200x300.jpg 200w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-redd-768x1152.jpg 768w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-redd-683x1024.jpg 683w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-redd-333x500.jpg 333w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-redd-150x225.jpg 150w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-redd-400x600.jpg 400w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-redd.jpg 1000w" sizes="(max-width: 200px) 100vw, 200px" srcset="https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-redd-200x300.jpg 200w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-redd-768x1152.jpg 768w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-redd-683x1024.jpg 683w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-redd-333x500.jpg 333w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-redd-150x225.jpg 150w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-redd-400x600.jpg 400w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-redd.jpg 1000w" /><figcaption class="hero-caption">Chuck Redd<span class="photo-credit"></span></figcaption><style>@media screen and (min-width: 568px) {#post-thumbnail-120612{max-width:333px;}}</style>    </a>
  </figure><!-- .entry-hero -->
  
  <div class="entry-excerpt">
    <p>Chuck ReddEvery summer, The Shedd’s Oregon Festival of American Music approaches its two-week series of concerts, films, talks and more from different angles, but its &hellip; <a href="https://eug.wkly.ws/2018/07/26/summer-standards/">Continue reading&nbsp;<span class="meta-nav">&rarr;</span></a></p>
  </div>

  <footer class="entry-footer">
    <hr class="empty-footer"/>  </footer>

</article><!-- #post-## -->

<article id="post-120628" class="excerpted-post excerpted-post-list post-120628 post type-post status-publish format-standard has-post-thumbnail hentry category-music has-post-img">
  <header class="entry-header">
    <h3 class="entry-title"><a href="https://eug.wkly.ws/2018/07/26/three-peas-in-a-pod/" rel="bookmark">Three Peas in a Pod</a></h3>
    
    <div class="entry-meta">
      <span class="excerpt-meta-item meta-item post-categories"><a href="https://eug.wkly.ws/category/arts/music/" class="post-category">Music</a></span> <span class="excerpt-meta-item meta-item posted-on"><a href="https://eug.wkly.ws/2018/07/26/three-peas-in-a-pod/" rel="bookmark"><time class="entry-date published updated" datetime="1532563224">7 hours ago</time></a></span>    </div><!-- .entry-meta -->
  </header><!-- .entry-header -->

    <figure class="entry-hero">
    <a href="https://eug.wkly.ws/2018/07/26/three-peas-in-a-pod/" rel="bookmark">
      <img width="150" height="150" src="https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-FiveLetterWord-150x150.jpg" class="aesop-lazy-img_not-yet" alt="" style="" srcset="https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-FiveLetterWord-150x150.jpg 150w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-FiveLetterWord-50x50.jpg 50w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-FiveLetterWord-200x200.jpg 200w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-FiveLetterWord-300x300.jpg 300w" sizes="(max-width: 150px) 100vw, 150px" srcset="https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-FiveLetterWord-150x150.jpg 150w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-FiveLetterWord-50x50.jpg 50w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-FiveLetterWord-200x200.jpg 200w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-FiveLetterWord-300x300.jpg 300w" />    </a>
  </figure><!-- .entry-hero -->
  
  <div class="entry-excerpt">
    <p>A Dixie summer means a toe-tapping mess of sun-kissed lovers, crisp iced tea and endless days spent soaking up the open air. Folk band Five &hellip; <a href="https://eug.wkly.ws/2018/07/26/three-peas-in-a-pod/">Continue reading&nbsp;<span class="meta-nav">&rarr;</span></a></p>
  </div>

  <footer class="entry-footer">
    <hr class="empty-footer"/>  </footer>

</article><!-- #post-## -->

<article id="post-120650" class="excerpted-post excerpted-post-list post-120650 post type-post status-publish format-standard has-post-thumbnail hentry category-music has-post-img">
  <header class="entry-header">
    <h3 class="entry-title"><a href="https://eug.wkly.ws/2018/07/25/post-post-punk/" rel="bookmark">Post-Post Punk</a></h3>
    
    <div class="entry-meta">
      <span class="excerpt-meta-item meta-item post-categories"><a href="https://eug.wkly.ws/category/arts/music/" class="post-category">Music</a></span> <span class="excerpt-meta-item meta-item posted-on"><a href="https://eug.wkly.ws/2018/07/25/post-post-punk/" rel="bookmark"><time class="entry-date published updated" datetime="1532534425">15 hours ago</time></a></span>    </div><!-- .entry-meta -->
  </header><!-- .entry-header -->

    <figure class="entry-hero">
    <a href="https://eug.wkly.ws/2018/07/25/post-post-punk/" rel="bookmark">
      <img width="150" height="150" src="https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-woolen-150x150.jpg" class="aesop-lazy-img_not-yet" alt="" style="" srcset="https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-woolen-150x150.jpg 150w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-woolen-50x50.jpg 50w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-woolen-200x200.jpg 200w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-woolen-300x300.jpg 300w" sizes="(max-width: 150px) 100vw, 150px" srcset="https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-woolen-150x150.jpg 150w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-woolen-50x50.jpg 50w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-woolen-200x200.jpg 200w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180726music-woolen-300x300.jpg 300w" />    </a>
  </figure><!-- .entry-hero -->
  
  <div class="entry-excerpt">
    <p>Portland weirdo-punkers The Woolen Men feel we’re living in a post-post world: post-punk, post-work, post-music industry. In fact, The Woolies have even named their new &hellip; <a href="https://eug.wkly.ws/2018/07/25/post-post-punk/">Continue reading&nbsp;<span class="meta-nav">&rarr;</span></a></p>
  </div>

  <footer class="entry-footer">
    <hr class="empty-footer"/>  </footer>

</article><!-- #post-## -->
</aside>  </div>
  <div class="widget">
    <aside id="twomostfeatured-3" class="widget two_most_featured">
<article id="post-120297" class="excerpted-post post-120297 post type-post status-publish format-standard has-post-thumbnail hentry category-slant has-post-img">
  <header class="entry-header">
    <h3 class="entry-title"><a href="https://eug.wkly.ws/2018/07/26/slant-31/" rel="bookmark">Slant</a></h3>
    
    <div class="entry-meta">
      <span class="excerpt-meta-item meta-item post-categories"><a href="https://eug.wkly.ws/category/news/opinion/slant/" class="post-category">Slant</a></span> <span class="excerpt-meta-item meta-item posted-on"><a href="https://eug.wkly.ws/2018/07/26/slant-31/" rel="bookmark"><time class="entry-date published updated" datetime="1532563244">7 hours ago</time></a></span>    </div><!-- .entry-meta -->
  </header><!-- .entry-header -->

    <figure class="entry-hero">
    <a href="https://eug.wkly.ws/2018/07/26/slant-31/" rel="bookmark">
      <img width="300" height="200" src="https://eug.wkly.ws/wp-content/uploads/2018/07/slant-image-300x200.jpg" class="aesop-lazy-img_not-yet" alt="" style="" srcset="https://eug.wkly.ws/wp-content/uploads/2018/07/slant-image-300x200.jpg 300w, https://eug.wkly.ws/wp-content/uploads/2018/07/slant-image-768x512.jpg 768w, https://eug.wkly.ws/wp-content/uploads/2018/07/slant-image-1024x683.jpg 1024w, https://eug.wkly.ws/wp-content/uploads/2018/07/slant-image-500x333.jpg 500w, https://eug.wkly.ws/wp-content/uploads/2018/07/slant-image-150x100.jpg 150w, https://eug.wkly.ws/wp-content/uploads/2018/07/slant-image-1250x833.jpg 1250w, https://eug.wkly.ws/wp-content/uploads/2018/07/slant-image-400x267.jpg 400w" sizes="(max-width: 300px) 100vw, 300px" srcset="https://eug.wkly.ws/wp-content/uploads/2018/07/slant-image-300x200.jpg 300w, https://eug.wkly.ws/wp-content/uploads/2018/07/slant-image-768x512.jpg 768w, https://eug.wkly.ws/wp-content/uploads/2018/07/slant-image-1024x683.jpg 1024w, https://eug.wkly.ws/wp-content/uploads/2018/07/slant-image-500x333.jpg 500w, https://eug.wkly.ws/wp-content/uploads/2018/07/slant-image-150x100.jpg 150w, https://eug.wkly.ws/wp-content/uploads/2018/07/slant-image-1250x833.jpg 1250w, https://eug.wkly.ws/wp-content/uploads/2018/07/slant-image-400x267.jpg 400w" />    </a>
  </figure><!-- .entry-hero -->
  
  <div class="entry-excerpt">
    <p>• In 2014 Joshua Hunt wrote in The New York Times about rape allegations against three University of Oregon basketball players. Now he has an &hellip; <a href="https://eug.wkly.ws/2018/07/26/slant-31/">Continue reading&nbsp;<span class="meta-nav">&rarr;</span></a></p>
  </div>

  <footer class="entry-footer">
    <hr class="empty-footer"/>  </footer>

</article><!-- #post-## -->

<article id="post-120461" class="excerpted-post post-120461 tribe_events type-tribe_events status-publish has-post-thumbnail hentry tribe_events_cat-gatherings cat_gatherings has-post-img">
  <header class="entry-header">
    <h3 class="entry-title"><a href="https://eug.wkly.ws/event/the-mother-earth-news-fair/" rel="bookmark">The Mother Earth News Fair</a></h3>
    <h4 class="entry-subhead"><a href="https://eug.wkly.ws/event/the-mother-earth-news-fair/" rel="bookmark">Linn County Expo Center &bull; 9:00 am &bull; <a href="https://www.motherearthnews.com/store/product-category/events" class="ticket-link">Tickets&rarr;</a></a></h4>
    <div class="entry-meta">
      <span class="excerpt-meta-item meta-item post-categories event-categories"><a href="https://eug.wkly.ws/calendar/" class="post-category event-category">Calendar</a><a href="https://eug.wkly.ws/calendar/category/gatherings/" rel="tag">Gatherings</a></span>    </div><!-- .entry-meta -->
  </header><!-- .entry-header -->

    <figure class="entry-hero">
    <a href="https://eug.wkly.ws/event/the-mother-earth-news-fair/" rel="bookmark">
      <img width="300" height="200" src="https://eug.wkly.ws/wp-content/uploads/2018/07/Kansas-Fair-PatJessi-Image-1-300x200.jpg" class="aesop-lazy-img_not-yet" alt="" style="" srcset="https://eug.wkly.ws/wp-content/uploads/2018/07/Kansas-Fair-PatJessi-Image-1-300x200.jpg 300w, https://eug.wkly.ws/wp-content/uploads/2018/07/Kansas-Fair-PatJessi-Image-1-768x512.jpg 768w, https://eug.wkly.ws/wp-content/uploads/2018/07/Kansas-Fair-PatJessi-Image-1-1024x683.jpg 1024w, https://eug.wkly.ws/wp-content/uploads/2018/07/Kansas-Fair-PatJessi-Image-1-500x333.jpg 500w, https://eug.wkly.ws/wp-content/uploads/2018/07/Kansas-Fair-PatJessi-Image-1-150x100.jpg 150w, https://eug.wkly.ws/wp-content/uploads/2018/07/Kansas-Fair-PatJessi-Image-1-1250x833.jpg 1250w, https://eug.wkly.ws/wp-content/uploads/2018/07/Kansas-Fair-PatJessi-Image-1-400x267.jpg 400w" sizes="(max-width: 300px) 100vw, 300px" srcset="https://eug.wkly.ws/wp-content/uploads/2018/07/Kansas-Fair-PatJessi-Image-1-300x200.jpg 300w, https://eug.wkly.ws/wp-content/uploads/2018/07/Kansas-Fair-PatJessi-Image-1-768x512.jpg 768w, https://eug.wkly.ws/wp-content/uploads/2018/07/Kansas-Fair-PatJessi-Image-1-1024x683.jpg 1024w, https://eug.wkly.ws/wp-content/uploads/2018/07/Kansas-Fair-PatJessi-Image-1-500x333.jpg 500w, https://eug.wkly.ws/wp-content/uploads/2018/07/Kansas-Fair-PatJessi-Image-1-150x100.jpg 150w, https://eug.wkly.ws/wp-content/uploads/2018/07/Kansas-Fair-PatJessi-Image-1-1250x833.jpg 1250w, https://eug.wkly.ws/wp-content/uploads/2018/07/Kansas-Fair-PatJessi-Image-1-400x267.jpg 400w" /><figcaption class="event-caption"><span class="event-month">Aug</span><span class="event-date">04</span></figcaption><style>@media screen and (min-width: 568px) {#post-thumbnail-120463{max-width:500px;}}</style>    </a>
  </figure><!-- .entry-hero -->
  
  <div class="entry-excerpt">
    <p>THE MOTHER EARTH NEWS FAIR Linn County Expo Center August 4th and 5th 2018 The Mother Earth News Fair provides you a rare opportunity: a &hellip; <a href="https://eug.wkly.ws/event/the-mother-earth-news-fair/">Continue reading&nbsp;<span class="meta-nav">&rarr;</span></a></p>
  </div>

  <footer class="entry-footer">
    <span class="featured-event">Sponsored Event</span>  </footer>

</article><!-- #post-## -->
</aside>  </div>
  <div class="widget">
    <aside id="acm_ad_zones-8" class="widget acm_ad_zones"><div class="ad ad-300x250-culture-atf-container"><div class="ad-wrapper">
		<div id='acm-ad-tag-%tag_id%' style='width:%width%px; height:%height%px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-%tag_id%'); });
</script>
		</div>
		</div></div>
</aside><aside id="acm_ad_zones-9" class="widget acm_ad_zones"><div class="ad ad-300x250-arts-atf-container"><div class="ad-wrapper">
		<div id='acm-ad-tag-300x250-arts-atf' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-300x250-arts-atf'); });
</script>
		</div>
		</div></div>
</aside><aside id="acm_ad_zones-10" class="widget acm_ad_zones"><div class="ad ad-300x250-news-atf-container"><div class="ad-wrapper">
		<div id='acm-ad-tag-%tag_id%' style='width:%width%px; height:%height%px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-%tag_id%'); });
</script>
		</div>
		</div></div>
</aside><aside id="currentissue-2" class="widget current_issue">    
        <aside class="post-118956 issue type-issue status-publish has-post-thumbnail hentry has-post-img">
      <header>Current Issue</header>
      <figure><img width="1118" height="1500" src="https://eug.wkly.ws/wp-content/uploads/2018/07/20180719cover.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://eug.wkly.ws/wp-content/uploads/2018/07/20180719cover.jpg 1118w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180719cover-224x300.jpg 224w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180719cover-768x1030.jpg 768w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180719cover-763x1024.jpg 763w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180719cover-373x500.jpg 373w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180719cover-150x201.jpg 150w, https://eug.wkly.ws/wp-content/uploads/2018/07/20180719cover-400x537.jpg 400w" sizes="(max-width: 1118px) 100vw, 1118px" /></figure>
      <footer>
        <a href="https://eug.wkly.ws/wheres-my-weekly/" class="button">Find a Paper</a>
              <a href="https://archive.org/details/20180719EW" class="button button-grey">Read this Issue</a>
            </footer>
    </aside>
    </aside>  </div>
</div><!-- #secondary -->

  </div><!-- #content -->

  <footer id="colophon" class="site-footer" role="contentinfo">

    <aside id="wpcom_social_media_icons_widget-2" class="widget widget_wpcom_social_media_icons_widget"><ul><li><a href="https://www.facebook.com/eugeneweekly/" class="genericon genericon-facebook" target="_blank"><span class="screen-reader-text">View eugeneweekly&#8217;s profile on Facebook</span></a></li><li><a href="https://twitter.com/eugeneweekly/" class="genericon genericon-twitter" target="_blank"><span class="screen-reader-text">View eugeneweekly&#8217;s profile on Twitter</span></a></li><li><a href="https://www.instagram.com/eugeneweekly/" class="genericon genericon-instagram" target="_blank"><span class="screen-reader-text">View eugeneweekly&#8217;s profile on Instagram</span></a></li><li><a href="https://www.youtube.com/user/eugeneweekly/" class="genericon genericon-youtube" target="_blank"><span class="screen-reader-text">View eugeneweekly&#8217;s profile on YouTube</span></a></li></ul></aside><aside id="nav_menu-2" class="widget widget_nav_menu"><nav class="navigation-menu -container"><ul id="menu-footer-navigation" class="menu"><li id="menu-item-56999" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56999 menu-item-find-a-paper"><a href="https://eug.wkly.ws/wheres-my-weekly/"><span class="menu-item-title">Find A Paper</span></a></li>
<li id="menu-item-56997" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56997 menu-item-advertise"><a href="https://eug.wkly.ws/advertise/"><span class="menu-item-title">Advertise</span></a></li>
<li id="menu-item-57000" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57000 menu-item-submit-an-event"><a href="https://www.eugeneweekly.com/calendar/event/add"><span class="menu-item-title">Submit An Event</span></a></li>
<li id="menu-item-69883" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69883 menu-item-promotions"><a href="https://eug.wkly.ws/promotional-opportunities/"><span class="menu-item-title">Promotions</span></a></li>
<li id="menu-item-61938" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61938 menu-item-masthead"><a href="https://eug.wkly.ws/masthead/"><span class="menu-item-title">Masthead</span></a></li>
<li id="menu-item-56998" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56998 menu-item-contact"><a href="https://eug.wkly.ws/contact-us/"><span class="menu-item-title">Contact</span></a></li>
</ul></nav></aside><aside id="copyright-2" class="widget widget_copyright">          <p class="copyright">© Eugene Weekly,&nbsp;2018</p>

    
    </aside>
  </footer><!-- #colophon -->
</div><!-- #page -->

		<!-- Aesop Lazy Loader -->
		<script>
			jQuery(document).ready(function($){
				$('.aesop-lazy-img').unveil(100,function() {
				  	$(this).load(function() {
				    	this.style.opacity = 1;
				  	});
				});
			});
		</script>
				<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done"}};/* ]]> */ </script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/eug.wkly.ws\/2018\/07\/26\/tajmo-return-for-mo\/":120630};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/2018/07/26/tajmo-return-for-mo/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://eug.wkly.ws/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<link rel='stylesheet' id='genericons-css'  href='https://eug.wkly.ws/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201830'></script>
<script type='text/javascript' src='https://eug.wkly.ws/wp-content/plugins/hyunsupul-aesop-core-0280b07/public/assets/js/ai-core.min.js?ver=1.9.10.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpURLs = {"template_directory_uri":"https:\/\/eug.wkly.ws\/wp-content\/themes\/soup2nuts","stylesheet_directory_uri":"https:\/\/eug.wkly.ws\/wp-content\/themes\/soup2nuts","siteurl":"https:\/\/eug.wkly.ws","wpurl":"https:\/\/eug.wkly.ws","url":"https:\/\/eug.wkly.ws"};
/* ]]> */
</script>
<script type='text/javascript' src='https://eug.wkly.ws/wp-content/themes/soup2nuts/assets/js/soup2nuts.js?ver=4.9.7'></script>
<script type='text/javascript' src='https://eug.wkly.ws/wp-includes/js/wp-embed.min.js?ver=4.9.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://eug.wkly.ws/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=6.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script type="text/css" id="tmpl-tribe_customizer_css">#tribe-events .tribe-events-calendar td.tribe-events-othermonth,
				#tribe-events .tribe-grid-allday,
				#tribe-events .tribe-week-today,
				#tribe-events .tribe-events-calendar td:hover {
					background-color: <%= month_week_view.cell_inactive_bg_color %>;
				}

				#tribe-events .tribe-events-calendar td,
				#tribe-events .tribe-week-grid-block div,
				#tribe-events .tribe-events-grid,
				#tribe-events .tribe-grid-allday,
				#tribe-events .tribe-events-grid .tribe-scroller,
				#tribe-events .tribe-events-grid .tribe-grid-body .column,
				#tribe-events .tribe-events-grid .tribe-grid-allday .column {
					border-color: <%= month_week_view.border_dark_color %>;
				}

				.events-archive.events-gridview #tribe-events-content table .type-tribe_events,
				.tribe-events-shortcode .tribe-events-month table .type-tribe_events {
					border-color: <%= month_week_view.border_light_color %>;
				}

				.tribe-events-calendar td.tribe-events-past div[id*="tribe-events-daynum-"],
				.tribe-events-calendar td.tribe-events-past div[id*="tribe-events-daynum-"] > a {
					background-color: <%= month_week_view.cell_inactive_header_bg_color %>;
				}

				.tribe-events-calendar div[id*="tribe-events-daynum-"],
				.tribe-events-calendar div[id*="tribe-events-daynum-"] a {
					background-color: <%= month_week_view.cell_header_bg_color %>;
				}

				.tribe-events-calendar thead th,
				.tribe-events-grid .tribe-grid-header .tribe-grid-content-wrap .column,
				.tribe-grid-header {
					background-color: <%= month_week_view.table_header_bg_color %>;
					border-left-color: <%= month_week_view.table_header_bg_color %>;
					border-right-color: <%= month_week_view.table_header_bg_color %>;
				}
			
				#tribe-events td.tribe-events-present div[id*="tribe-events-daynum-"],
				#tribe-events td.tribe-events-present div[id*="tribe-events-daynum-"] > a {
					background-color: <%= month_week_view.highlight_color %>;
					color: #fff;
				}

				#tribe-events .tribe-events-grid .tribe-grid-header div.tribe-week-today {
					background-color: <%= month_week_view.highlight_color %>;
				}

				.tribe-grid-allday .tribe-events-week-allday-single,
				.tribe-grid-body .tribe-events-week-hourly-single,
				.tribe-grid-allday .tribe-events-week-allday-single:hover,
				.tribe-grid-body .tribe-events-week-hourly-single:hover {
					background-color: <%= month_week_view.highlight_color %>;
					background-color: <%= month_week_view.highlight_color_rgba %>;
					border-color: <%= month_week_view.highlight_border_color %>
				}</script><style type="text/css" id="tribe_customizer_css">#tribe-events .tribe-events-calendar td.tribe-events-othermonth,
				#tribe-events .tribe-grid-allday,
				#tribe-events .tribe-week-today,
				#tribe-events .tribe-events-calendar td:hover {
					background-color: #f1f1f1;
				}

				#tribe-events .tribe-events-calendar td,
				#tribe-events .tribe-week-grid-block div,
				#tribe-events .tribe-events-grid,
				#tribe-events .tribe-grid-allday,
				#tribe-events .tribe-events-grid .tribe-scroller,
				#tribe-events .tribe-events-grid .tribe-grid-body .column,
				#tribe-events .tribe-events-grid .tribe-grid-allday .column {
					border-color: #d2d2d2;
				}

				.events-archive.events-gridview #tribe-events-content table .type-tribe_events,
				.tribe-events-shortcode .tribe-events-month table .type-tribe_events {
					border-color: #e4e4e4;
				}

				.tribe-events-calendar td.tribe-events-past div[id*="tribe-events-daynum-"],
				.tribe-events-calendar td.tribe-events-past div[id*="tribe-events-daynum-"] > a {
					background-color: #d2d2d2;
				}

				.tribe-events-calendar div[id*="tribe-events-daynum-"],
				.tribe-events-calendar div[id*="tribe-events-daynum-"] a {
					background-color: #acacac;
				}

				.tribe-events-calendar thead th,
				.tribe-events-grid .tribe-grid-header .tribe-grid-content-wrap .column,
				.tribe-grid-header {
					background-color: #464646;
					border-left-color: #464646;
					border-right-color: #464646;
				}
			
				#tribe-events td.tribe-events-present div[id*="tribe-events-daynum-"],
				#tribe-events td.tribe-events-present div[id*="tribe-events-daynum-"] > a {
					background-color: #eaeaea;
					color: #fff;
				}

				#tribe-events .tribe-events-grid .tribe-grid-header div.tribe-week-today {
					background-color: #eaeaea;
				}

				.tribe-grid-allday .tribe-events-week-allday-single,
				.tribe-grid-body .tribe-events-week-hourly-single,
				.tribe-grid-allday .tribe-events-week-allday-single:hover,
				.tribe-grid-body .tribe-events-week-hourly-single:hover {
					background-color: #eaeaea;
					background-color: rgba( 234, 234, 234, .75 );
					border-color: #c3c3c3
				}</style><script type='text/javascript' src='https://stats.wp.com/e-201830.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.1',blog:'142358727',post:'120630',tz:'-7',srv:'eug.wkly.ws'} ]);
	_stq.push([ 'clickTrackerInit', '142358727', '120630' ]);
</script>
<style type="text/css"></style>
</body>
</html>

<!-- Dynamic page generated in 20.286 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2018-07-26 00:05:10 -->

<!-- Compression = gzip -->